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Symptoms:
When using the Data Migration Tool to convert a HDM-4 Version workspace the following message is shown:
Cause :
[1] The data migration tool makes the assumption that the user converting the files has HDM-4 Version 1.3 installed on the system as well. If you receive the -2071 error, the error message usually indicates that the HDM-4 Version 1.3 dictionary files (that describe the format of the data stored in the workspace files) could not be found.
[2] There is an initialisation file that tells the Data Migration Tool where the HDM-4 Version 1.3 dictionary files can be found. If this file is not configured correctly the -2071 error message will be displayed.
Solution :
[1] If you do not have HDM-4 Version 1.3 software installed you will need to download the required dictionary files (HDM-4 Version 1.3 Dictionary Files) from the link below.
The download should be placed in the following directory (or language variant equivalent) to ensure they are found by the tool:
C:\Program Files\HDM-4\hdmdict or
C:\Program Files (x86)\HDM-4\hdmdict
depending on your versions of windows operating system. This folder should now contain the following two files:
_objects.dat
_objects.idx
[2] The initialisation file that tells the Data Migration Tool where the dictionary files can be found is called POET.CFG, and this is in the same folder as the Data Migration Tool executable file, typically:
C:\Program Files\HDM-4 Version 2\migrationTool or
C:\Program Files (x86)\HDM-4 Version 2\migrationTool
You should check that this has the correct location for the above files defined within it. It should be formatted as follows:
[schemata\HDMDICT]
name = C:\Program Files\HDM-4\HDMDICT
or
[schemata\HDMDICT]
name = C:\Program Files (x86)\HDM-4\HDMDICT
depending where the HDM-4 Version 1.3 dictionary files mentioned above in [1] are located.
NOTE: There are two POET.CFG files in use for HDM-4 software - one for the main application, and one for the Data Migration Tool - it is important that you check and edit the correct one otherwise you may prevent HDM-4 Version 2 software from opening workspaces.
Knowledge Base Support Downloads
Below are the downloads to support the knowledge base articles above; download the files mentioned in the article.
Find out about the technical support service offered by HDMGlobal to help users use HDM-4 effectively.
For existing HDM-4 users, view the latest software release and the changes made before registering to receive the updates.
Find out about HDM-4 training courses offered by HDMGlobal and their partner organisations and other related events.